What you need to install Pype


Last updated March 3rd, 2016

PHP 5.4+, Git, ssh access to remote host.
Node.js with Gulp and Browsersync installed globally, if using the provided Pype themes.

Composer

Like Yii2: Composer with the Composer asset plugin globally installed.

Deployer

To install Deployer download the Deployer phar archive:

http://deployer.org/deployer.phar

Then install it globally:

mv deployer.phar /usr/local/bin/dep
chmod +x /usr/local/bin/dep

Github API token

You need to generate a Github API token.

You can do that from your Github profile settings menu: Github API token

Docs repository

Create a repository on Github for your content - documents and images.

Webhook

Add a webhook to your content repository: Webhook

Pype template

Install Pype:

composer create-project --prefer-dist --stability=dev jacmoe/pype mypypesite

Edit on Github

Contributors to this page